4. Using the Console

The iTivity console is the control center for iTivity. It provides the interface for administrators and support personnel to view and manage computers that are connected to an hyperserver.

To open the iTivity console, click on the shortcut icon you may have installed on your desktop during installation, or select Start > All Programs > iTivity > iManager > iTivity iManager.

Notes on Customization

-You can use the Windows Command Prompt or create Windows shortcuts to launch the console with various special options. See Section 3.4, Customizing Console Startup with Command Line Shortcuts.

-Advanced users can customize the iTivity console to turn on or off the display of specific options. This chapter describes the standard, non-customized console interface. For information on customizing the interface, contact iTivity Support.

-Individual agent systems can also be customized to disable certain types of remote access, such as Windows RDP, Telnet, or Chat. For information, see Section 2.3, Controlling agent Service Access Permissions in the iTivity Deployment Guide.

4.1 Main Menu Bar

The Main Menu bar is located at the top of the iTivity console window.

4.1.1 File Menu Options

The File menu allows you to create and manage lists of hyperservers that are displayed in the left pane of the Main Window. You only need these options if you are have multiple hyperservers and want to manage them in different lists. These lists can be saved to disk, merged, and have passwords applied to them. The lists are saved as files with a .ncn extension.

4.1.1.1 New

Use this option to clear the current list of hyperservers so you can create a new list.

1. Close any open hyperserver connections.

2. Choose File > New.

3. If you have made changes to the current scan file, you will be asked if you wish to save the current list.

If you wish to save your current list, click Yes. Otherwise click No.

The list is cleared from the pane.

4. You can now create a new list by adding hyperservers. See Section 4.1.2.1, Add iTivity Hyperserver for instructions.

4.1.1.2 Open

To open a previously saved hyperserver list:

1. Select File > Open.

2. Select the correct location of the list file (the last saved file is automatically displayed), enter the file name, and click Open.

The saved list is displayed in the pane.

4.1.1.3 Save

Use this option to save the current hyperserver list. The list is saved under whatever filename you last opened. If no list file was opened, the list is saved as default.ncn.

4.1.1.4 Save As

The Save As option allows you to save the active list with a new file name, whether it is a previously saved file that you retrieved or a list not already saved to a file.

1. Select File > Save As to open the Save As dialog box.

2. Select the directory to store the file and enter the file name. The current file name is listed by default.

3. Click Save As.

4.1.1.5 Merge

The Merge option allows you to combine the active list with a previously saved list.

1. Select File > Merge to display the Merge dialog box.

2. Select the saved list file (*.ncn file) that you want to merge with the current one.

3. Click Merge.

The files are merged and the combined list is displayed in the left pane.

4.1.1.6 Passwords

The Passwords option allows you to assign a password to the currently displayed list (*.ncn file). Once a password is assigned, the list is password-protected. Anyone attempting to display the list will have to enter the password.

1. Select File > Passwords to display the File Password dialog box.

2. To add a password, fill in the New Password and Confirm Password fields. To change an existing password, you also need to fill in the Old Password field.

To remove an existing password, enter the old password and leave the other fields blank. This removes the password protection from the file.

3. Click OK button to save the change.

4.1.1.7 Exit

To close the iTivity console select File > Exit.

Other ways to exit the application include:

s Using the hot key combination [Alt+X].

s Clicking on the iTivity icon located in the upper left-hand corner of the iTivity console screen and selecting Close.

s Clicking on the X in the upper right-hand corner of the iTivity console screen.

4.1.2 Edit Menu

The Edit menu allows you to add, delete, or change hyperserver information.

4.1.2.1 Add iTivity Hyperserver

Use this option to add an iTivity hyperserver to your list. You must add hyperservers before you can view computers attached to those hyperservers.

1. Click the Edit Menu and choose Add iTivity Hyperserver .

The new iTivity Hyperserver dialog is displayed.

2. Fill in the information.

iTivity hyperserver name

The server DNS name

IP address

IP address for the hyperserver. You can fill in either the IP address or the hyperserver name.

List-View Port number

The default value of 25800 is provided but can be edited if a different port is used on this hyperserver.

Description

Optional Description of the hyperserver displayed in the console.

3. Click OK.

The hyperserver is added and displayed in the pane on the Main Window.

4.1.2.2 Delete

Use this option to delete unnecessary hyperservers from your list.

1. Highlight the hyperserver you wish to delete.

2. Select Edit > Delete.

3. Click Yes to confirm the delete action.

Other ways to access the Delete option include:

s Selecting the Delete icon from the toolbar.

s Right-clicking on the highlighted hyperserver or node and selecting Delete from the pop-up menu.

s Using the hot key combination [Ctrl+D].

4.1.2.3 Modify

Use this option if you need to change the definition of an iTivity hyperserver or secure dial site that has already been added to your list.

1. In the pane, highlight the hyperserver or secure dial site.

2. Click the Edit Menu and choose Modify.

The Modify iTivity hyperserver dialog or Modify Secure Dial Site dialog is displayed.

3. Change the information as needed. For hyperservers, see Section 4.1.2.1 for information.

4. Click OK.

The definition is changed and the dialog closes.

4.1.3 Action Menu Options

The Action menu allows you to initiate or terminate remote control sessions. It also allows you to initiate TELNET, Chat or File Transfer sessions.

4.1.3.1 Remote Desktop

Note: You can initiate a standard remote viewing session without Terminal Services/RDP using the View option or the Connect option, as described later in this chapter.

The Remote Desktop option allows you to initiate a remote viewing session through Windows Terminal Services or Remote Desktop Protocol (RDP). The remote Windows computer must be running Microsoft Terminal Services/RDP and must be connected to an hyperserver using either the attended agent or unattended agent.

This option allows you to use Windows Terminal Services/RDP while taking advantage of the secure encryption offered by the iTivity agents.

Note: This option is available on Windows XP, Vista and Windows 2003. For more information, contact iTivity Support.

When to Use

If you are using iTivity 5.1.00 and later consoles and agents, you can create a new Windows session using Remote Desktop.

If you need to share a desktop with a logged on user, then View is the correct option. This is normally the case for providing technical support to a user.

If you need to have exclusive access to a desktop or create a new desktop, then either Remote Desktop or Remote Desktop Console (see Section 4.1.3.2) is the correct option. This is normally the case for remote administration of the agent system.

Note: If you are viewing a Windows session created by another user via RDP connection, and if the other user minimizes their RDP viewer, then there are no screen updates to that session. This causes the screen to go black if you attempt to View that session. If you are already viewing that session, then the screen freezes. This is because the operating system does not notify the agent of the change, so there is no way to indicate that the session has gone inactive.

Using remote desktop

1. If necessary, expand the network list in the left-hand pane until the desired computer is visible.

2. Highlight the computer that you want to view.

3. Select Action > Remote Desktop or press the Ctrl+T hotkey combination.

4. If this is the first time your iTivity console is connecting to this computer, you may be asked to verify the requested encryption certificate fingerprint of the computer.

Note: This option depends on how the attended agent or unattended agent was installed. This can be controlled by editing the HTML file used to download and install the agents. See Section 5.4, Editing the agent HTML Files.

If verifying the certificate number is required, the number can be obtained by right-clicking on the iTivity icon in the agent computer's system tray and selecting the Show Certificate Fingerprint option. Your computer retains the fingerprint in its cache for the next viewing session.

5. The console displays messages indicating that it is building the tunnel and then waiting for authentication. The Authentication dialog is displayed.

Note: The Authentication dialog depends on the authentication method used by the agent, which is determined when the agent is installed. For information on installing the agents, see Chapters 5 and Chapter 8 in this guide.

6. Enter your User Name and Password. Optionally, enter the Reason for connecting. Click OK.

Note: Whether the Reason field is used depends on your organization. If used, the Reason entered is logged in the hyperserver Activity Log for auditing by administrators. See Section 2.12, hyperserver Activity Log for more information on the activity log.

The RDP Windows Login dialog appears:

7. Enter the User Name and Password as required by Windows.

The login is processed and the screen image for the remote computer appears. The Windows Local Host control bar appears in the viewer for you to control the remote session:

8. When you are ready to close the RDP session, click the X in the control bar.

4.1.3.2 Remote Desktop Console

The steps for using the Remote Desktop Console menu option are the same as for using the Remote Desktop option. See Section 4.1.3.1 for instructions.

Note: This option is available on Windows XP, Vista and Windows 2003. For more information, contact iTivity Support.

4.1.3.3 View

The View option allows you to initiate a remote viewing session with an agent computer that is currently connected to an hyperserver. The procedure differs for viewing agents over the Internet and viewing via secure dial.

Note: To initiate a viewing session with a Linux computer running the unattended agent, use the Connect option. See Section 4.1.3.14, Connect/Disconnect.

Extended Remote Access in iTivity v 5.2: Beginning with v 5.2, the iTivity WebTunnel feature discovers and allows you to remotely access applications available on the agent computer through network connections. For more information, see Section 1.5.1, Configuring iTivity WebTunnel.

Viewing an Agent over the internet

1. If necessary, expand the network list in the pane until the desired computer is visible.

2. Highlight the computer that you want to view.

3. Select Action > View to start the connection process.

4. If this is the first time your iTivity console is connecting to this computer, you may be asked to verify the requested encryption certificate fingerprint of the computer.

Note: This option depends on how the attended agent or unattended agent was installed. This can be controlled by editing the HTML file used to download and install the agents. See Section 5.4, Editing the agent HTML Files.

If verifying the certificate number is required, the number can be obtained by right-clicking on the iTivity icon in the agent computer's system tray and selecting the Show Certificate Fingerprint option. Your computer retains the fingerprint in its cache for the next viewing session.

5. The console displays messages indicating that it is building the tunnel and then waiting for authentication. The Authentication dialog is displayed.

Note: The Authentication dialog depends on the authentication method used by the agent, which is determined when the agent is installed. For information on installing the agents, see Chapter 5 and Chapter 8 in this guide.

6. Enter your User Name and Password. Optionally, enter the Reason for connecting. Click OK.

Note: Whether the Reason field is used depends on your organization. If used, the Reason entered is logged in the hyperserver Central Audit Log for auditing by administrators. See Section 2.12, hyperserver Activity Log for more information on the activity log.

The login is processed and the screen image for the agent computer appears in a separate window on your screen. Also, the color of the agent computer changes in the left pane to indicate it is now connected.

4.1.3.4 End Session

The End Session option closes all connections with an agent computer, including any View, Chat, TELNET, and FTP connections. Also, the tunnel is closed and the session does not remain cached. This means iTivity console must open a new tunnel and you will need to log in again to view the computer.

1. Highlight the computer you close the session with.

2. Select Action > End Session.

3. Click Yes at the prompt.

4.1.3.5 Expand

Use this option to expand the view of an hyperserver to display the currently connected agent computers, or to expand the view of a Linux server to display the currently connected terminal sessions and services.

1. Highlight the node to expand in the left-hand pane of the Main Window.

2. Select Action > Expand.

Other ways to access the Expand option include:

Selecting the Expand icon from the toolbar.

Right-clicking on the highlighted node and selecting Expand from the pop-up menu.

Using the hot key combination [Ctrl+E].

4.1.3.6 Expand All Nodes

To fully expand all nodes:

Select Action > Expand All Nodes. OR Use the hot key combination [Ctrl+A].

4.1.3.7 Collapse

Use this option if you want to collapse the view of a single hyperserver or Linux server node.

1. Highlight the hyperserver you wish to collapse in the left-hand pane of the Main Window.

2. Select Action > Collapse.

Other ways to access the Collapse option include:

s Selecting the Collapse icon from the toolbar.

s Right-clicking on the highlighted node and selecting Collapse from the pop-up menu.

s Using the hot key combination [Alt+C].

4.1.3.8 Collapse All

To fully collapse all nodes:

Select Action > Collapse All. OR Use the hot key combination [Alt+(minus sign)].

4.1.3.9 File Transfer

The File Transfer option lets you easily move, copy, or delete files on agent computers.

1. If necessary, expand the view in the pane of the Main Window to display the agent computer.

2. Highlight the computer that you want to transfer files to or from.

3. Select Action > File Transfer.

4. Depending on which authentication method was chosen during installation of the attended agent or unattended agent, iTivity displays a dialog to enter the log-in information.

5. Enter the log-in information as required.

6. If this is the first time you've selected the File Transfer option, a setup dialog is displayed.

Click Yes to store your file transfer settings in the registry or No to store them in an XML file (recommended).

7. The File Transfer window is displayed.

The pane shows the folders and files on the local (viewer) computer. The right-hand pane shows the directories and files on the agent computer.

See File Transfer Window below for more information about the features of this window.

8. To copy files, select the files or folders you want to copy in the left or right pane, and drag and drop them to the appropriate folder in the other pane.

To delete a file or folder on either the agent or your local computer, right-click on the file and choose Delete from the popup menu.

9. To end the File Transfer session, choose File > Exit.

File Transfer Window

This window serves as an FTP client and offers many standard FTP features. For example, from the Transfer menu, you can choose the default transfer type as ASCII, Binary, or auto-detect, and you can choose settings for whether files of the same name will be automatically overwritten.

This table explains the tool bar icons in the File Transfer window.

Site Manager - Opens the Site Manager window, which allows you to define and manage remote FTP sites.

Show or hide a directory tree view of the local computer.

Show or hide a directory tree view of the agent computer.

Show or hide a pane showing files in the queue waiting to be transferred.

Show or hide a message log, which records status and any error messages.

Refresh all views.

Process files currently in the queue.

Cancel the current operation.

Disconnect from the computer.

Reconnect to the server (available after the connection has been cancelled.)

Display online help for the File Transfer Window.

4.1.3.10 TELNET

The TELNET option allows you to initiate a TELNET session with a Windows, or Linux system. TELNET is a standard terminal emulation program type for TCP/IP networks. It allows you to remotely enter commands as though they were entered on the server console. TELNET sessions with Linux systems are encrypted and require a login.

To open a TELNET session, do the following:

1. Highlight the computer with which you want to open the TELNET session.

2. Select Action > TELNET.

The iTivity console opens a tunnel and displays the Authentication dialog:

3. Enter your user name and password and click OK.

The TELNET window is displayed. You can now log in and issue commands.

TELNET Window Menu Options

Within the TELNET window, the following menu options are available:

Session Menu

Connect

Reconnects if the session has been disconnected.

Disconnect

Disconnect the session.

Print Screen

Prints the current terminal console display.

Close

Terminates the session and closes the TELNET window.

Edit Menu

Copy

Copies the text currently selected in the window to the Windows clipboard.

Paste

Pastes the contents of the Windows clipboard into the window at the cursor location.

Select All

Selects all text currently displayed in the window.

Options Menu

Font Size

Lets you select the font size for character display in the window.

Keyboard

Loads a graphic keyboard extension to allow you to use special keys.

Emulation

Lets you change the terminal emulation type for viewing the TELNET host.

Rows

Lets you adjust the number of rows shown in the window.

Columns

Lets you adjust the number of columns shown in the window.

Scroll Bar

Toggles the window scroll bar on and off.

Help Menu

Topics

Displays online Help for using iTivity.

About

Displays information about the version of iTivity.

4.1.3.11 SSH

The SSH option allows you to initiate a secure shell or SSH session with a Windows or Linux system. The SSH session opens in a standard terminal emulation program type for TCP/IP networks. It allows you to remotely enter commands as though they were entered on the server console. SSH sessions with Linux systems are encrypted and require a login.

To open an SSH session, do the following:

1. Highlight the computer with which you want to open the SSH session.

2. Select Action > SSH.

The iTivity console opens a tunnel and displays the Authentication dialog:

3. Enter your user name and password for the agent and click OK.

The SSH user name dialog is displayed. Enter the user name for the SSH session. This may be a different user name than you used in the previous dialog for the agent access permission, if any.

4. Enter your SSH user name and click OK.

The SSH password dialog is displayed. Enter the password for the SSH user name from the previous dialog.

5. Enter your SSH password and click OK.

The SSH window is displayed. You are already logged in and ready to issue commands.

SSH Window Menu Options

Within the SSH window, the following menu options are available:

Session Menu

Connect

Reconnects if the session has been disconnected.

Disconnect

Disconnect the session.

Print Screen

Prints the current terminal console display.

Close

Terminates the session and closes the SSH window.

Edit Menu

Copy

Copies the text currently selected in the window to the Windows clipboard.

Paste

Pastes the contents of the Windows clipboard into the window at the cursor location.

Select All

Selects all text currently displayed in the window.

Options Menu

Font Size

Lets you select the font size for character display in the window.

Keyboard

Loads a graphic keyboard extension to allow you to use special keys.

Emulation

Lets you change the terminal emulation type for viewing the SSH host.

Rows

Lets you adjust the number of rows shown in the window.

Columns

Lets you adjust the number of columns shown in the window.

Scroll Bar

Toggles the window scroll bar on and off.

Help Menu

Topics

Displays online Help for using iTivity.

About

Displays information about the version of iTivity.

4.1.3.12 Refresh

The Refresh option rescans the hyperservers in the list to show the current connections.

1. In the left pane, highlight the hyperserver you want to refresh.

2. Choose Action > Refresh or press the Ctrl+R hot-key combination.

4.1.3.13 Connect/Disconnect

The Connect option is used to open a connection to an hyperserver. If the currently selected hyperserver is already connected, then this option is changed to Disconnect.

This option is also used to connect to and then view a Linux agent computer. See Connecting to the unattended agent on Linux, in this section.

To Connect to an Hyperserver

1. In the left pane, highlight the hyperserver you want to connect to.

2. Click the Connect toolbar button, or click the Action Menu and choose Connect. You can also double-click on the hyperserver in the left pane.

The console displays messages indicating that it is building the tunnel and then waiting for authentication. The Authentication dialog is displayed

3. Enter your User Name, Password, and Support Domain (if applicable) and click OK.

Note: If your network uses Active Directory domains, you must enter the domain along with the user name, for example "MYDOMAIN\user name". Contact your network administrator if you need assistance.

The connection is established. The connected hyperserver changes in the left pane to a light green color.

To DisConnect an Hyperserver

1. In the pane, highlight the hyperserver you want to disconnect from.

2. Click the Disconnect toolbar button, or choose Action > Disconnect.

3. Click Yes at the prompt.

Connecting to the Unattended Agent on Linux

The Connect option is also used to connect to Linux servers running the unattended agent and to their terminal sessions or services.

Extended Remote Access in iTivity v 5.2: Beginning with v 5.2, the iTivity WebTunnel feature discovers and allows you to remotely access applications available on the agent computer through network connections. For more information, see Section 1.5.1, Configuring iTivity WebTunnel.

To remotely view the Linux computer, do the following:

1. Highlight the Linux computer and click the Connect toolbar button or choose the Action > Connect option. You can also double-click on the computer in the left pane.

The console displays messages indicating that it is building the tunnel and then waiting for authentication. The Authentication dialog is displayed.

2. Enter your user name and password for the Linux computer and click OK.

The connection is established and the current terminal sessions and services are displayed below the Linux node.

3. To view one of the terminal sessions or services, highlight it in the list and click the View toolbar button or choose the Action > Connect option again. You can also double-click on one of the services or sessions to connect.

A viewer window opens, displaying the service or terminal session.

Note: For TELNET sessions, a secure login dialog is displayed.

To end the remote control session, click the End View toolbar button, or choose Action > Disconnect.

Connecting to an X Windows Session on a Linux Unattended Agent

Beginning with iTivity v 5.2, you can also use the Connect option to view X Windows desktops on Linux agents. This feature provides secure remote access to Linux graphical consoles.

To remotely view an X Windows session, do the following:

1. Highlight the Linux computer and click the Connect toolbar button or choose the Action > Connect option. You can also double-click on the computer in the left pane.

The console displays messages indicating that it is building the tunnel and then waiting for authentication. The Authentication dialog is displayed.

2. Enter your user name and password for the Linux computer and click OK.

The connection is established and the current terminal sessions and services are displayed below the Linux node.

3. Highlight the X Windows session and click the View toolbar button, or choose the Action > Connect option again. You can also double-click on the highlighted session to connect.

A viewer window opens, displaying the X Windows desktop session.

To close an X Windows session, click the lock icon in the upper left hand corner of the Viewer and select Close.

4.1.3.14 Remove Agent from Hyperserver

Use this option to close the connection between a listed computer or server and the hyperserver. You can also prevent this computer from reconnecting at a later time. This option is available only when a connected agent computer is highlighted in the pane.

Caution: Once an agent is removed from the hyperserver, remote viewing and control is disabled. The connection can only be re-established by restarting the agent at the remote computer or server.

1. In the pane, beneath a connected hyperserver, highlight the computer or server you want to disconnect.

2. Choose Action > Remove Agent from Hyperserver.

The Remove/Restart agent dialog is displayed.

3. Choose an option:

Stop agent until restarted again

The computer will be able to reconnect to this hyperserver at a later time.

Block agent from connecting again

The computer will be blocked from reconnecting

4. Click OK.

iTivity issues a Warning requiring you to confirm the action.

5. Click Yes to proceed or Cancel to cancel.

4.1.3.15 License Status

Use this option to display the License status for the currently selected hyperserver. First highlight the hyperserver in the pane, then right click to highlight option to display the License Status dialog:

Note: If you've updated your license, you can click the Refresh button to update the dialog. The dialog is automatically refreshed every 30 seconds it is displayed.

4.1.4 Tools Menu Options

Selecting the Tools menu gives you access to various iTivity tools, including powerful remote control options designed for support personnel.

4.1.4.1 Find...

The Find option can be used to search an extensive network list for a specific text string, making it easy to find a particular hyperserver or agent system node.

1. Choose Tools > Find.

The Find dialog is displayed.

2. Type the string you want to search for.

3. Click the Find Next button.

The network list is searched and if the text is found, the node is highlighted.

4. Click the Find Next button to search again or the Cancel button to close.

4.1.4.2 Filter...

The Filter option is another tool for managing the view of extensive network lists. You can choose to filter the list to show only nodes that contain a specific text string. You can also clear a filter to display your entire list.

Filter > New

To filter the network list, do the following:

1. Choose Tools > Filter > New.

The Filter dialog is displayed.

2. Type the text string that you want to use as your filter. If desired, click the Match case box.

3. Click the Apply button.

The network list is displayed with only the nodes that contain the filter text string you entered.

Filter > Clear

Use the Clear option to remove a filter and redisplay the entire network list.

Choose Tools > Filter > Clear.

The entire network list is displayed.

4.1.4.3 Sort

The Sort option is another tool for managing the view of extensive network lists. You can sort by any of the options listed on the flyout menus and you can choose Ascending or Descending order. You can also turn a Match Case option on or off.

1. Choose Tools > Sort.

The Sort flyout menu is displayed.

2. Click the attribute you want to use for sorting: Operating System, Machine name, etc.

Or click Ascending or Descending as desired.

Or choose to turn on or off the Match Case toggle option.

The menu closes and the network list is resorted according to your selection.

4.1.4.4 Properties

Selecting the Properties option opens a Properties dialog for the currently-highlighted hyperserver or computer.

This information is for review only. Modifications cannot be made through the Properties dialog.

Note: The session ID shown is a unique serial number for each connected agent computer.

4.1.4.5 Options

The Options option opens a three-tabbed dialog allowing you to select connection options, adjust general options (such as the refresh interval) and to modify security options.

Note: The Options settings apply to the local computer when it runs as an agent. That is, when it has the attended agent or unattended agent installed and is being viewed by an iTivity console installed on another computer. If neither agent is installed, these settings have no effect.

Connections

Selecting Tools > Options opens the Connections dialog, allowing you to make global changes to the iTivity console. These become the default connection settings used by the local machine.

Preferred encoding

Automatically Select Encoding iTivity automatically selects the encoding and compression method based on the connection speed.

If you clear the Automatically Select Encoding checkbox, you can manually choose from the following options:

-Tight Designed for use over slow modem connections; uses more sophisticated sampling and analysis to determine the most efficient representation. Recommended on very slow connections, less than 64 Kbps.

-ZlibHex (mix) Attempts to achieve the low CPU use of hextile with better compression of zlib by strategically using zlib compression in the hextile framework.

-Hextile This is the default and the preferred method in most situations.

-Zlib (pure) Uses standard zlib compression routines for each update. Recommended over moderate connections, 64 to 256 Kbps.

-CoRRE Compressed Rise-and-Run length Encoding; uses one byte for the width and height of each colored rectangle.

-Raw Should only be used with high-speed, uncongested networks.

-RRE Rise-and-Run length Encoding; represents all updates as a set of colored rectangles.

-Allow CopyRect encoding Allows for faster updates during window drags but may cause screen distortion with some connections. Try it with your current session. If you experience problems, turn it off by unselecting the box.

-Custom compression level: Level (1=fast, 9=best) Selects a trade-off between more compression and higher CPU use in zlib, zlibhex, and eventually tight encodings. Use lower numbers for faster networks and less-available CPU time. Use higher numbers for slower networks and more available CPU time.

-Allow JPEG compression: Quality (0=poor, 9=best) Allows the user to select the preferred JPEG compression level for the viewing session.

Misc.

-Request shared session This option asks the agent to leave any existing connections open, allowing you to share the desktop with someone already using it. This is the default setting. If you try to initiate a non-shared session while other connections are in place, the agent will reject the request instead of dropping the existing connections. If you request a non-shared session when no other connections are active, your request is processed and subsequent requests for a session are rejected by the agent.

-Deiconify on Bell If the agent is running on a machine using a bell message (a beep notifying the user that email has arrived, for example), the agent will transmit this bell message, causing a beep at the viewer if it has sound facilities. If the viewer is minimized during the process, receiving the bell message will cause the viewer to un-minimize.

-Disable clipboard transfer Clipboard changes caused by cutting or copying at either the viewer or server end are normally transmitted to the other end. This option disables clipboard transfers.

Mouse

-Emulate 3 Buttons Allows users with a two-button mouse to emulate a middle button by pressing both buttons at once. This option is enabled by default.

-Swap mouse buttons 2 and 3 PC mouse buttons are normally mapped as 1,2,3. Selecting this option causes them to be mapped as 1,3,2. This may be more useful for two-button users who only have left-right, since they will then get buttons 1 and 2 instead of 1 and 3.

Mouse cursor

-Track remote cursor locally This option gives you faster cursor updates.

-Let remote server deal with mouse cursor The viewed machine redraws its cursor every time.

-Do not show remote cursor This option displays only the viewer cursor.

Display

-Restrict pixels to 8-bit The viewer will normally accept whatever pixel format the agent offers and do the translation locally. Selecting this option forces it to request 8-bit true-color (BGR233) from the agent. This helps reduce network traffic and is useful over modems.

-View only In this mode, no mouse or keyboard events are sent back to the agent. This is useful for training sessions where you want to observe but not interfere.

-Full-screen mode Selecting this option causes connections to start in full-screen mode by default.

-Scale by n/m This specifies a scaling factor for the local display. The values should be integers. This feature is used to resize the viewer window so that it is easier to work with. For example, entering a value of 1/2 will cause the viewer window to resize to one-half of its original height/width, while a value of 2/1 causes the viewer to double the size of the viewer window.

General

Scan and display settings for the local machine can be changed through the General tab (Tools > Options > General).

Network Scanning

Scan for DHCP IP address changes

You can specify how often iTivity scans for address changes on networks where DHCP is enabled. Increasing the Refresh interval is another way to speed up the scanning.

Display Options

You can use these options to limit the types of connected computers to display:

-iTivity Windows nodes

-Linux nodes

-TTY nodes

Security

This tab is available only when:

-You have an agent installed on the computer along with the console

-You chose NTLM as the authentication method when installing the agent.

Note: The encryption and authentication settings on this tab apply to the installed agent, not to the hyperserver. After changing settings on the Security tab and clicking OK to exit, you must stop and then restart the agent for the changes to take effect.

Encryption

This option enables/disables the encryption capability of the local computer when it acts as an agent.

Authentication

Allows you to change the authentication method of the local machine after iTivity is installed.

LDAP/NDS- The user connects to this agent using either the Lightweight Directory Access Protocol (LDAP) or Novell Directory Services (NDS). If you choose this option, you need to enter the authentication information below.

NTLM - The user is asked to supply the agent's User Name and Password (the same login id and password the agent uses to log on to the Windows network).

VNC - The user is asked to supply a simple password only.

None - The user is not asked to provide any password.

VNC Password

Allows you to change the Simple password of the local computer after iTivity is installed. This option is only available if Simple is selected as the authentication method.

LDAP/NDS Authentication

This area of the dialog becomes available when you choose LDAP/NDS as the Authentication option above.

Encryption Determines whether LDAP authentication connections will be encrypted.

Host The host name or IP address of the LDAP/NDS server.

Port Number Optional port number for connecting to a server on a non-standard port. Leave this blank if you are unsure, and the standard port number will be used.

SSL Certificate path Only needed when encryption is enabled. Specifies the location of the DER encoded certificates containing the trusted public key(s) of the LDAP server in use.

Authentication User Tree Context The location of the user objects in the LDAP tree. To authenticate with the LDAP server, a user's object must be within the server tree branch given here. Specifying the exact location can greatly speed up lookups on heavily loaded servers. Values in this field might look something like the following:

ou=AcmeUsers,ou=user,o=acme??sub OR dc=users,dc=acme,dc=com

Authentication Group Object Distinguished Name The name of the particular authorization group on the LDAP server that grants a user permission to use iTivity to access the agent system. To access the agent system across the network, the user must be a member of this group or a nested group.

4.1.5 Help Menu Options

4.1.5.1 Topics

Selecting Help > Topics opens the iTivity console online help, delivered in a standard help format, complete with a table of contents, index, and full-text search functionality.

4.1.5.2 About

Selecting Help > About displays version and license information about your iTivity installation.

4.2 Toolbar

The toolbar consists of shortcuts to many of the available menu options.

Used to connect to an hyperserver, or start a viewing session with the Linux computer or terminal session highlighted in the left-hand pane.

Starts a viewing session for the agent computer currently highlighted in the left pane.

Opens an SSH session to the agent computer currently highlighted in the left pane. Linux servers and some desktops can be targets for secure shell connections. See Section 4.1.3.11, SSH for more information.

Opens an RDP session to the agent computer currently highlighted in the left pane. Windows servers and desktops are typical targets for remote desktop connections.

Ends the active viewing session with the agent highlighted in the left pane.

Opens the find dialog to search for one or more agents by string or pattern. See Section 4.1.4.1, Find for more information.

Opens the File Transfer window and allows you to initiate a file transfer session with the agent currently selected in the left pane. See Section 4.1.3.9, File Transfer for more information.

Opens a TELNET session with the agent computer currently selected in the left pane. See Section 4.1.3.11, TELNET for more information.

4.3 Agent System Tray Menu

When you open a remote control session with a Windows computer through the iTivity console the session appears in the Windows task bar, with a lock icon and the agent computer's name.

The agent System Tray menu provides options for controlling the remote control session. To access this menu, right-click on the task bar. Or, while viewing the agent, click on the lock icon in the top left-hand corner of the window.

Restore

Restores the agent desktop to its previous size and location.

Move

Allows you to move the agent desktop on your screen.

Size

Allows you to alter the size of the agent desktop on your screen.

Minimize

Reduces the agent desktop to an icon in the taskbar.

Maximize

Enlarges the agent desktop to fill the screen.

Close

Closes the viewer and ends the remote control session. The agent computer continues running.

Connection options

Displays the TridiaVNC Viewer Options dialog. TridiaVNC Viewer is the module that actually handles remote view and control of the agents.

Connection Tab

Format and Encodings

Use encoding:

You can manually select from the following options:

ZLRE - (Default) Designed for machines with low bandwidth but ample CPU capacity.

Hextile - Hextile encoding is usually the best choice for use in high-speed network environments (for example, Ethernet local-area networks).

Tight Designed for use over slow modem connections; uses more sophisticated sampling and analysis to determine the most efficient representation. Recommended on very slow connections, less than 64 Kbps.

RRE Rise-and-Run length Encoding; represents all updates as a set of colored rectangles.

CoRRE Compressed Rise-and-Run length Encoding; uses one byte for the width and height of each colored rectangle.

Zlib (pure) Uses standard zlib compression routines for each update. Recommended over moderate connections, 64 to 256 Kbps.

ZlibHex (mix) Attempts to achieve the low CPU use of hextile with better compression of zlib by strategically using zlib compression in the hextile framework.

Use 8-bit Color

The viewer will normally accept whatever pixel format the agent offers and do the translation locally. Selecting this option forces it to request 8-bit true-color (BGR233) from the agent. This helps reduce network traffic.

Custom compression level

You can check this option and use the slider to select a custom compression level with values from 1 to 9. Use lower numbers for faster networks and less-available CPU time. Use higher numbers for slower networks and more available CPU time.

Allow JPEG compression: Quality (0=poor, 9=best)

Allows the user to select the preferred JPEG compression level for the viewing session. This option is available only when Tight is chosen as the Use Encoding option.

Allow CopyRect encoding

When this option is checked, it allows for faster updates during window drags but may cause screen distortion with some connections. Try it with your current session. If you experience problems, turn it off by clearing the check box.

Restrictions

View only

In this mode, no mouse or keyboard events are sent back to the agent. This is useful for training sessions when you want to observe but not interfere.

Disable Clipboard Transfer

Clipboard changes caused by cutting or copying at either the agent or console end are normally transmitted to the other end. This option disables clipboard transfers.

Display

Scale by

Specifies a scaling factor for the local display. This feature is used to resize the viewer window so that it is easier to work with. For example, selecting a value of 75% will cause the viewer window to that is 3/4 of the original height and width.

Full-screen mode

Selecting this option causes connections to start in full-screen mode by default.

Deiconify on remote Bell event

If the agent is running on a machine using a bell message (a beep notifying the user that email has arrived, for example), the agent will transmit this bell message, causing a beep at the viewer if it has sound facilities. If the viewer is minimized during the process, receiving the bell message will cause the viewer to un-minimize.

Mouse

Emulate 3 Buttons (with 2-button click)

Allows users with a two-button mouse to emulate a middle button by pressing both buttons at once. This option is enabled by default.

Swap mouse buttons 2 and 3

PC mouse buttons are normally mapped as 1,2,3. Selecting this option causes them to be mapped as 1,3, 2. This may be more useful for two-button users who only have left-right, since they will then get buttons 1 and 2 instead of 1 and 3.

Mouse cursor

Track remote cursor locally - This option gives you faster cursor updates.

Let remote server deal with mouse cursor - The viewed machine redraws its cursor every time.

Don't show remote cursor This option displays only the viewer cursor.

Request Shared Session

This option asks the agent to leave any existing connections open, allowing you to share the desktop with someone already using it. This is the default setting. If you try to initiate a non-shared session while other connections are in place, the agent will reject the request instead of dropping the existing connections. If you request a non-shared session when no other connections are active, your request is processed and subsequent requests for a session are rejected by the agent.

Globals Tab

Interface Options

Show toolbars by default: Displays the TridiaVNC Viewer toolbar at the top of the view window. Enabled by default.

Warn at switching to the full-screen mode: When full-screen mode is selected, confirm full-screen mode selection and inform the user how to exit full-screen mode. Enabled by default.

Number of connections to remember: Not applicable to iTivity.

Clear the list of saved connections: Click the button to clear the list of saved connections.

Local cursor shape

This setting determines how the mouse cursor for the local (console) machine is represented. The default is a dot cursor.

Listening mode

The TCP port number to listen for incoming VNC server connection requests. Not used with iTivity.

Logging

Disabled by default. Check this option to have the TridiaVNC Viewer write a log file of its activity. When checked, you can select a name and location for the log file, and also choose the level of detail (Verbosity level) between 1 and 12.

Connection info

Selecting this option opens the VNC connection info box that provides agent and connection information.

Request screen refresh

Allows you to conveniently refresh the agent screen.

Full screen

Allows you to switch the viewer to full-screen mode. See Section 4.4.1, Full Screen Mode, for more information.

Fit Window

Allows you to resize the display of the agent screen to fit inside a window on your desktop. The agent desktop image is automatically scaled to fit into the viewer window on your system.

Send Ctl-Alt-Del

Because the keystrokes [Ctl]+[Alt]+[Del] may be interpreted by the local machine, this option is provided for sending [Ctl]+[Alt]+[Del] to the agent computer.

Send Ctl-ALT-Esc

Because the keystrokes [Ctl]+[Alt]+[Esc] may be interpreted by the local machine, this option is provided for sending [Ctl]+[Alt]+[Esc] to the agent computer.

Ctrl kEY Down

The keystrokes [Ctl]+[] may be interpreted by the local machine. Use this option to send [Ctl]+[] to the agent machine.

Alt kEY Down

The keystrokes [Alt]+[] may be interpreted by the local machine. Use this option to send [Alt]+[] to the agent machine.

tRANSFER fILES

This option opens a File Transfers window that allows you to copy files between the (local) console computer and the (remote) agent computer. Initially, the drive letters for each machine are listed. Double-click on a drive letter, or use the buttons at the top of the list to navigate to the files you want to copy.

About iTivity viewer...

The About box displays version information for the iTivity Viewer software.

4.3.1 Full-Screen Mode

The viewer can be switched into a full-screen mode. This is particularly useful when connecting to an agent screen that is the same size as your local one. If the agent screen is bigger, you won't get any scrollbars, but you can scroll by bumping the mouse against the edge of the screen.

To exit full-screen mode, you can enter [Ctrl]+[Alt]+[Shift]+[F]. Or you can type [Ctrl]+[Esc]+[Esc], then right-click on the agent task to open the agent System menu and uncheck the Full screen option.

When you select full-screen mode, a dialog appears with instructions:

4.4 iTivity Product Support

Product support is available from iTivity by web site or email:

Copyright © 2004 - 2019, iTivity Corporation Copyright and License Information